MyBB Documentation

Requirements

Below is a list of basic requirements for MyBB. You must have these requirements fulfilled before MyBB can work on your website.

A host with the following:

  • PHP version 5.1.0 or above with XML Extension installed
    • Note: If you want to use MyBB 1.4.x, PHP version 4.3.11 or above would be required
  • MySQL version 4.0 or above, PostgreSQL, or SQLite
  • FTP access (or another way to upload the MyBB software to your web server)

Have everything you need? Read the Installation Guide for instructions on installing.

The following tools may help you setup and administer your forum, but are not absolutely required for the operation of your forum:

It is recommended that you find a web host which does not force advertisements on your site. Forced advertisements sometimes output to browser before MyBB expects it, causing blank screens, and users not being able to login.

What is MyBB? - License - Features - Requirements - Installing - Upgrading - MyBB Team

Edit on GitHub